Announcement

Collapse
No announcement yet.

Anon-user

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Anon-user

    I have just set this up on my domain but the block history is showing anon-user instead of the actual username

    How do I fix this?

    Click image for larger version

Name:	image.png
Views:	30
Size:	59.5 KB
ID:	2968

  • #2
    You have to enable User Athetication on 'System > Setup'. And then create users or import users.
    Last edited by support200; 05-20-2024, 12:26 AM.

    Comment


    • #3
      I seem to have fixed that issue but now no policy is enforced, the users are listed and LDAP connection successful but on the client machine it is no longer applying the policy

      Comment


      • #4
        They need to be under Default policy if you create new users. If you want to apply other policies, read https://forum.nxfilter.org/tips-tric...em-of-nxfilter

        Comment


        • #5
          I am trying to import users and groups in AD (which is working) however my base DN is DC=home,DC=lan

          Which imports all groups and users, however i dont want it to target admins i.e. domain ads, enterprise and so on

          Do I have do manually delete those groups or change their policy individually?

          Comment


        • #6
          Also nothing is currently being blocked and i am not sure why, also enabled user authentication but it still shows anon-user

          Comment


          • support200
            support200 commented
            Editing a comment
            Did you block anything on any policy? Your users need to go throug a login process to appear with their username.

        • #7
          Maybe you need to see how to block something by NxFilter first. https://www.youtube.com/watch?v=yvYN...nnel=Jahastech

          Comment


          • #8
            I know how to block things I checked every category and selected block all just to test and make sure it works but the problem is when I add another IP and create new DNS records for NxFilter to fix the port 53 binding issue, the client machine does not sync with or recognise the filter, obviously I am doing something wrong.

            I have imported all my users and groups and the LDAP connection succeeds.

            Comment


            • #9
              Does your client PC sends DNS quries to NxFilter? Does it appear on 'Logging > Request?

              If so, try 'nslookup google.com' on CMD of the PC. Then it shows which DNS server it is using. See if there's secondary DNS server or an IPv6 DNS server for the PC.

              And when you test if NxFilter working of not, it's always a good idea to verify it with Nslookup or Dig.

              Comment

              Working...
              X